Archive for July, 2009

RNC 1773 repair

Sunday, July 5th, 2009

Five years ago I ordered an FMR Audio RNP 8380 preamp and RNC 1773 compressor bundled with a Funk Logic FRT-8373 rack tray from Mercenary Audio. Mercenary is located overseas from me, as I live in Germany, so the weak Dollar in relation to the Euro was the main reason to order directly from the U.S.; aided by the fact that local prices for FMR Audio gear were comparatively unattractive (virtually not nice) at that time. This has changed meanwhile.

Well, although I’ve not the least doubt that Mercenary Audio would do everything to help me in case of a damage or malfunction, there is still the shipping time and cost to and from overseas if a repair becomes necessary. And last tuesday evening, when I hung out in my vocal booth, the worst case became true: all gain reduction LEDs of my RNC started to light up without an audio signal applied. After I switched it off and on again the LEDs still kept lit. Then I observed that turning the RATIO knob straight to the left made them turn off, but with just a few degrees turned to the right they all lit up again.

Would the german distributor be delighted to fix it for me? I did not ask but switched to plan B: become a geek and fix it by myself.

Easier said than done. After one hour of component checking I sat there without having a clue. Before, when I opened the housing and first saw the three voltage regulators, I would have bet dollars euros to donuts that either one of the two 15 volts regulators is broken. But they were not.

After having put a pot of coffee on, downloading datasheets and digging in somewhat deeper into the circuit, I stumbled upon a 5.37 volts input signal on port 16 (AD0) of the CPU. Up to four ports of the 68HC705 can be used for A/D conversion, and all of them are utilized that way in the RNC; exactly matching it’s block diagram, the three pots RATIO, ATTACK and RELEASE are connected to AD1 to AD3, and AD0 seems to be feeded with the equivalent audio input sum signal brought over from output 3 of U4 (TL074, not in the main audio path, mentioned for the enthusiasts).

Back to the 5.37 volts on AD0: do they make sense if the reference voltage on pin 15 of the 68HC705 is exactly 5.0 volts? Probably not. Tracing back the path to U4 made me say “thank you” to diode D3 for its job to protect the CPU from being blown: output 3 of U4 showed about +10 volts, with the non-inverting input 3 connected to ground and the inverting input 3 hanging around at +5 volts.

So I removed U4, which was btw more delicate to desolder than expected due to the surrounding resistor networks on the component side, and replaced it with a new TL074 in a precision ic-socket. Luckily that did the trick and the RNC is now fully operational again.